Announcement

Collapse
No announcement yet.

[SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

    Hello,

    Just had an issue with a client that migrated to OTM v5.5. As part of the migration, Oracle Reports gets upgraded to 10.1.2.0.2 (from 9.2.0.4) and several problems have ensued.

    One of the more frustrating issues is that reports upgraded from 9.2.0.4 do not correctly display in the new version of Reports -- even though they do correctly display in the Oracle Reports Developer application. Some of these formatting issues can be tackled by manipulating your HTML tags within the reports, but they still remain VERY troublesome.

    In order to resolve this issue, we've applied the following patches:
    (Note: you need to request a custom patch from Oracle as several of these patches conflict with each-other)
    • 4157095
    • 5085162
    • 5515739
    • 5497522 (Reports User exits failing)
    • 6082506 (HTML / CSS formatting issue)
    However, the issue remains with some reports. The only sure-fire solution we've found to-date is to start from scratch and re-design the reports in the latest version of Oracle Reports Developer 10g, rather than upgrading your reports.

    Hope this helps!

    --Chris
    Chris Plough
    twitter.com/chrisplough
    MavenWire

  • #2
    Re: [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

    Hi Chris,

    With respect to information given above, do you think the problem which we are facing is having the same problem.

    I have attached a screenshot for this issue.

    I would request you to kindly view and suggest us. Please do let me know if you are unable to view the attachment if by chance. Also on metalink I could not find the patch 6082506 using Patch Number in the drop downlist of metalink.

    Thanks and Regards,
    Suresh
    Attached Files
    Last edited by [email protected]; November 5, 2007, 13:19.

    Comment


    • #3
      Re: [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

      Dear Chris,

      Request you to please have a suggestion on this issue. Appreciate your help.

      Thanks and Regards,
      Suresh

      Comment


      • #4
        Re: [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

        Suresh,

        Your screenshot is exactly the behavior that several of our clients have experienced when running OTM v5.5 Reports on the Windows platform. We've verified this with all of the stock OTM Reports, so it isn't a custom report issue.

        I just marked this thread as unsolved, since we still have an open Oracle SR on this issue and they are being very slow to resolve. If you have an SR, please update us as to the progress and I'll do the same.

        --Chris
        Chris Plough
        twitter.com/chrisplough
        MavenWire

        Comment


        • #5
          Re: [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

          FYI - the final resolution to this issue was to use a patched rw.dll file for Oracle Reports, which fixes all of the HTML formatting issues associated with Oracle Reports on Win32.

          [Edited - see the post below for the download link]

          If you're facing this issue, send me a message and I'll do my best to point you in the right direction, so that you can obtain this (or a similar) fix to resolve the issue.

          --Chris
          Last edited by chrisplough; January 5, 2008, 17:15.
          Chris Plough
          twitter.com/chrisplough
          MavenWire

          Comment


          • #6
            Re: [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

            It doesn't seem that distributing the DLL will be an issue. I've attached it below. Just backup and replace the rw.dll file with the one provided below (unzip it first, of course).

            Download Link: rw.dll.zip

            This has already worked for several people, and helps get past this PITA issue

            --Chris
            Chris Plough
            twitter.com/chrisplough
            MavenWire

            Comment


            • #7
              Re: [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

              Hi Chris,

              This works perfectly. Thanks very much for the patch.

              Regards,
              Suresh

              Comment


              • #8
                Re: [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

                Hi Chris,

                Volvo has recently upgraded from 5.0 to 5.5.03.
                They are also facing the same report issue (format in HTML).
                If I am not wrong, the above dll is for Windows System.
                Will this works for Unix Box (Report Server) also?

                Thanks In Advance
                Nikesh

                Comment


                • #9
                  Re: [SOLVED] HTML Formatting issues with Oracle Reports 10.1.2.0.2

                  Nikesh,

                  If you are getting formatting issues in Linux/Solaris then either the report has a problem or there is a problem with the installation of Oracle Reports. There should not be any formatting issues on Linux/Solaris.

                  Nick
                  If my post was helpful please click on the Thanks! button

                  MavenWire Hosting Admin
                  15 years of OTM experience

                  Comment

                  Working...
                  X