No announcement yet.

[SOLVED] RWServletProxy Exception: when Running Reports

This topic is closed.
  • Time
  • Show
Clear All
new posts

  • [SOLVED] RWServletProxy Exception: when Running Reports


    If you receive the following error when running reports, it generally means that your a portion of your OTM Reports architecture is either down or inaccessible (i.e. network issue).

    An exception occurred while attempting to access the remote report web server.
    RWServletProxy Exception:
    Description: null
    To resolve, I'd recommend first restarting all of your Reports components: Oracle Reports, rptapache and rpttomcat (v5.0 and earlier). If the problem persists, then run port tests via telnet to ensure everything is network accessible.

    If the problem persists beyond that, post a reply to this thread and I'll try to help out.

    Hope this helps!

    Chris Plough

  • #2
    Re: RWServletProxy Exception: when Running Reports

    We have same problem, seems that restarting solve it...
    But this is the n-problems with ORACLE report server...
    We had our customers VERY unsatisfied with Reports OTM part...

    Does anybody know a way to stabilize this Bulls..t REPORT SERVER
    There is a memory configuration that prevent these continuos problems
    There is a suggested version better than others (but howevere supported by OTM)
    THanks in advance for any suggestion

    Stefano Giommi

    e: [email protected]


    • #3
      Re: RWServletProxy Exception: when Running Reports


      What version of OTM are you running? I ask because the architecture was significantly different before OTM/GC3 v5.0. I'll assume OTM v5.0/v5.5 based on your previous posts, but let me know if otherwise.

      Try the following next time you experience this problem:
      1. Restart just rptapache
        1. Test to see if that fixes the issue
      2. Restart just the Oracle Reports server
        1. Test to see if that fixes the issue
      3. Restart just the OTM Web Tier (Apache/Tomcat)
        1. Test to see if that fixes the issue
      That will help isolate the cause of the issue. Let me know how this goes and I can help you moving forward.

      A few quick best-practices for reports:
      1. Prior to OTM v5.0, Win32 was the best (most stable) Oracle Reports platform
      2. For v5.0 and later, Linux appears to be the best platform
      3. Whenever possible, keep your OTM Oracle Reports instance separate from any other reporting instances -- i.e. don't combine with an existing Oracle Reports Server
      4. Use the separate Forms/Reports installer that Oracle provides, not the full Oracle Application Server installation - this uses far less resources and is much more stable.
      5. Ensure that you clear out your Oracle Reports cache directories regularly, otherwise you can end up with directories that have thousands of files, causing performance and stability issues.
      6. As with all OTM tiers, restart on a regular basis: weekly or bi-weekly. Some clients can get away with monthly, but shorter intervals are more common.
      The integration between OTM and Oracle Reports has definitely been one of the most difficult parts of OTM - so you're not alone in your frustration. With some work, though we may be able to stabilize your environment.

      I hope this helps!

      Chris Plough