Announcement

Collapse
No announcement yet.

Configurations settings to internet enable OTM

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Configurations settings to internet enable OTM

    Hi All,

    What are the configuration changes do i need to make, so that my OTM instance can be accessible from anywhere through the internet.

    Currently we have the instance accessible only within our local network through the ip.

    We are into v5.5 CU4 and using Tomcat, Apache as our web server,OAS as app server and RedHat Enterprise Linux as our OS.

    Any suggestions/help on this would be useful.
    Regard's
    Arun

  • #2
    Re: Configurations settings to internet enable OTM

    Change the following entry in your glog.properties

    # web server URL (may differ from server name)
    glog.webserver.URL=

    This is your external FQDN


    Nick
    If my post was helpful please click on the Thanks! button

    MavenWire Hosting Admin
    15 years of OTM experience

    Comment


    • #3
      Re: Configurations settings to internet enable OTM

      Nick,

      Thanks for the reply.

      I have made the changes to the properties file and my entries looks like below,

      # web server URL (may differ from server name)
      glog.webserver.URL=http://otm.mycompany.com:80$glog.webserver.urlprefix$

      Also we have enabled the reverse proxy request for the FQDN, http://otm.mycompany.com

      But still the instance is not accessible by the url from outside our network.

      Do i miss something else. Kindly advise.
      Regard's
      Arun

      Comment


      • #4
        Re: Configurations settings to internet enable OTM

        That's only going to configure the DNS side of things so that when you work within otm and get emails tenders etc they will work. You still need to configure your firewall to point to the web server.
        If my post was helpful please click on the Thanks! button

        MavenWire Hosting Admin
        15 years of OTM experience

        Comment


        • #5
          Re: Configurations settings to internet enable OTM

          Hi Nick

          I have the same problem with my instance.Iam unable to access to out of my local network.I followed the steps that u have prescribed above. Can you please ellaborate the firewall configuration setup u have mentioned in your previous post?. As iam a non-technical person kindly let me know about this in detail, so that i can let my technical folks to work on this.

          Regards

          Comment


          • #6
            Re: Configurations settings to internet enable OTM

            Arun,

            I just saw your note on another post and realize that you are using the Microsoft ISA server. This behaves significantly different from the default behavior of most reverse-proxy servers.

            I've included my reply from the other post below:
            Arun,

            Microsoft ISA server behaves differently than the Apache-based reverse-proxy servers (WebSphere, Netegrity, Aventail, etc) and does not conform the the behavior that OTM expects. We have a couple of clients that use it and it took a lot of discovery and hacking in order to get it to work.

            As a result, you'll need to remove the reverse-proxy configuration in OTM (glog.webserver.urlprefix and edits to the index.html file) and configure the Microsoft ISA server to have a dedicated IP address that always forwards back to the OTM instance. You'll need this one-to-one configuration for the communication to work properly.

            --Chris __________________
            Chris Plough
            MavenWire

            www.MavenWire.com
            --Chris
            Chris Plough
            twitter.com/chrisplough
            MavenWire

            Comment


            • #7
              Re: Configurations settings to internet enable OTM

              Originally posted by enjoyOTM View Post
              Hi Nick

              I have the same problem with my instance.Iam unable to access to out of my local network.I followed the steps that u have prescribed above. Can you please ellaborate the firewall configuration setup u have mentioned in your previous post?. As iam a non-technical person kindly let me know about this in detail, so that i can let my technical folks to work on this.

              Regards

              Has your networking team opened port 80 to this server on the firewall? If they have and you still can't reach it from the outside, I would suggest you have them look into their network setup since you can access it from the inside.
              If my post was helpful please click on the Thanks! button

              MavenWire Hosting Admin
              15 years of OTM experience

              Comment


              • #8
                Re: Configurations settings to internet enable OTM

                Arun,

                I'm not a Microsoft ISA administrator, though I did work with the experts at two of our clients in order to configure this. So - while I can't share the exact configuration, I can tell you that ISA needs to be setup to provide a one-to-one external IP to internal IP mapping and this is the way it needs to be configured in order to work with OTM. As a result, it requires a dedicated external IP address and ISA must also be configured not to manipulate the HTML paths that are a part of the OTM Web server response.

                --Chris
                Chris Plough
                twitter.com/chrisplough
                MavenWire

                Comment


                • #9
                  Re: Configurations settings to internet enable OTM

                  Originally posted by chrisplough View Post
                  Arun,

                  I'm not a Microsoft ISA administrator, though I did work with the experts at two of our clients in order to configure this. So - while I can't share the exact configuration, I can tell you that ISA needs to be setup to provide a one-to-one external IP to internal IP mapping and this is the way it needs to be configured in order to work with OTM. As a result, it requires a dedicated external IP address and ISA must also be configured not to manipulate the HTML paths that are a part of the OTM Web server response.

                  --Chris
                  Thanks Chris....We'll have our network team to look into your suggestion.
                  Regard's
                  Arun

                  Comment


                  • #10
                    Re: Configurations settings to internet enable OTM

                    Originally posted by chrisplough View Post
                    Arun,

                    I'm not a Microsoft ISA administrator, though I did work with the experts at two of our clients in order to configure this. So - while I can't share the exact configuration, I can tell you that ISA needs to be setup to provide a one-to-one external IP to internal IP mapping and this is the way it needs to be configured in order to work with OTM. As a result, it requires a dedicated external IP address and ISA must also be configured not to manipulate the HTML paths that are a part of the OTM Web server response.

                    --Chris

                    We got our issue fixed...

                    Thanks once again chris for your valuable suggestions...!
                    Regard's
                    Arun

                    Comment


                    • #11
                      Re: Configurations settings to internet enable OTM

                      Arun,

                      Congrats - I'm glad that you were able to work past the issue!

                      Please share the details of your solution - so that others here in the community can benefit.

                      Thanks,
                      Chris
                      Chris Plough
                      twitter.com/chrisplough
                      MavenWire

                      Comment


                      • #12
                        Re: Configurations settings to internet enable OTM

                        Originally posted by chrisplough View Post
                        Arun,

                        Congrats - I'm glad that you were able to work past the issue!

                        Please share the details of your solution - so that others here in the community can benefit.

                        Thanks,
                        Chris
                        Chris,

                        We have removed the url prefix from the glog properties and edited the index.html file.

                        And added the FQDN to the web server url properties

                        # web server URL (may differ from server name)
                        glog.webserver.URL=http://otm55.mycompany.com:80$glog.webserver.urlprefix$


                        On the Microsoft ISA side, we created a rule sayin that every request that comes to the RP to forward it to the webserver.

                        It worked...!
                        Regard's
                        Arun

                        Comment


                        • #13
                          Re: Configurations settings to internet enable OTM

                          Most of the clock settings are based off the timezone of the user who initiates the startup (with the exception of the database). You will need to set the user's timezone to reflect what you are looking for.
                          I'm not a Microsoft ISA administrator, though I did work with the experts at two of our clients in order to configure this. So - while I can't share the exact configuration, I can tell you that ISA needs to be setup to provide a one-to-one external IP to internal IP mapping and this is the way it needs to be configured in order to work with OTM. As a result, it requires a dedicated external IP address and ISA must also be configured not to manipulate the HTML paths that are a part of the OTM Web server response.


                          ________________________________________

                          Want to get-on Google's first page and loads of traffic to your website? Hire a SEO specialist from Ocean Groups seo specialist

                          Comment


                          • #14
                            Re: Configurations settings to internet enable OTM

                            Originally posted by arunk View Post
                            Chris,

                            We have removed the url prefix from the glog properties and edited the index.html file.

                            And added the FQDN to the web server url properties

                            # web server URL (may differ from server name)
                            glog.webserver.URL=http://otm55.mycompany.com:80$glog.webserver.urlprefix$


                            On the Microsoft ISA side, we created a rule sayin that every request that comes to the RP to forward it to the webserver.

                            It worked...!
                            Hi Chris/Arun,

                            I have been reading other threads too related to Reverse Proxy but this seemed close to how I may have to do it for our configuration. We are using Squid as reverse proxy on OTM 6.3.2. Since squid does a one-on-one mapping for IP/hostname, I believe I do not have to set glog.webserver.urlprefix. So I left it blank. Same with index.htm. No changes there.

                            We did a rewrite in the squid file like below:

                            $url =~ m/^https:\/\/otmextp\.mydomain\.com([\/]*)$/) {
                            print "302:https:\/\/otmextp\.mydomain\.com/GC3/glog.webserver.servlet.umt.Login\n"


                            When I am launching the URL from my browser (https://otmextp.mydomain.com), I am seeing Squid error "Unable to forward this request at this time". I am also not seeing any evidence in the OTM logs on my webserver that Squid even forwarded the request. If something hits the webserver, I should find in access_log (right?). We hit a dead-end.

                            Our requirement is that majority of users will access OTM internally. However there are a few external users that will use the external URL (https://otmextp.mydomain.com) which we are trying to route through reverse proxy.

                            Any help is appreciated.

                            Thanks,
                            Vikram

                            Comment


                            • #15
                              Re: Configurations settings to internet enable OTM

                              Hi Team,

                              Did anyone else have to configure reverse proxy on OTM using Squid? If yes, any help is appreciated.

                              Thanks,
                              Vikram

                              Comment

                              Working...
                              X