Announcement

Collapse
No announcement yet.

BPEL Server - Timeout Values for OTM

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BPEL Server - Timeout Values for OTM

    Hey Chris,

    Thanks for the heads-up. One more question...we have reviewed the recommended timeout settings for OTM and Fusion from Oracle. We are finding these settings to be too short for some of our very large trx to process.

    In your experience, what have you found these settings to most optimal? Files with transaction-timeout in server.xml, domain.xml, orion-ejb-jar.xml, transaction-manager.xml and syncMaxWaitTime (on Fusion).

    Any insight on your experience with these settings would be of value.

    Thanks,
    Jeff

  • #2
    Re: Invalid state of package in BPEL

    Jeff,

    So far, for Client A, we've only had to update a single BPEL timeout value, which is the "transaction-config timeout" specified in the server.xml file. We set the value as follows:

    server.xml
    Code:
    <transaction-config timeout="300000" />
    For Client B, we had to change a two, as follows:

    server.xml
    Code:
    <transaction-config timeout="300000" />
    domain.xml
    Code:
    <property id="syncMaxWaitTime">
            <name>Delivery result receiver maximum wait time</name>
            <value>120</value>
    We also had to increase the Java Heap (memory allocation) of the BPEL server to get it to process more efficiently and reduce transaction times. The minimum heap I would consider for your BPEL server is 1024MB.

    Haven't had to adjust any of the other files that you referenced, but these may be due to the version of BPEL that you are using?

    Thanks,
    Chris
    Chris Plough
    twitter.com/chrisplough
    MavenWire

    Comment


    • #3
      Re: BPEL Server - Timeout Values for OTM

      We already have the memory heap size set to 2GB so I think we are good there, but increasing the timeout definetly made a difference. In Fusion 10.1.3.3 the file name is transaction-manager.xml and the parameter is transaction-timeout="xxxx".

      We had increased before from the default setting but only to around 14400 (I think we doubled it from the original default setting -twice). We were only able to process smaller volumes or ranges of deliveries with batch sizes of 10 or less. The conc req in EBS was failing with null pointer exception and we could not consistently reproduce (mixing and matching different volumes with batch sizes).

      After changing the parameter above and the transaction-timeout in orion-ejb-jar.xml - we are able to process large volumes with batchsizes up to 50 deliveries (possibly more, just have not tried yet).

      Also to note is that these settings got replaced (as expected) when we upgraded from 10.1.3.1 to 10.1.3.3 of Fusion. We had to go in and rest them all again after the upgrade. Changing the value of "syncMaxWaitTime" in domain.xml file had no effect as it was reset back to default upon container startup. This setting is controllable in the BPEL console manager and I guess they expect you to change it from the application side rather than at the OS level.

      -jeff

      Thanks again for your help.

      Comment

      Working...
      X