Announcement

Collapse
No announcement yet.

Error in Tender Response Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in Tender Response Integration

    Hello - I am trying to partially accept THUs from a shipment tender through integration. This works as expected for the first time I upload the Tender response XML. The original shipment (status: SECURE RESOURCES PARTIALLY ACCEPTED) is updated with 'available THU count' correctly and the agent also creates a new shipment (status: SECURE RESOURCES ACCEPTED) with the 'THU count' that was accepted.

    But when I try to integrate the same XML again i.e for the second time (same Tender Transaction Number and Ship Unit GID, Accepted THU count < Available THU count) I do not see the split shipment ,The original shipment is also not updated. The log is showing an array-out-of-bounds exception. The Servprov, workflow parameter, Agent configuration is in place.

    However when I try to perform the partial acceptance on this tender for the same THU and same count through UI, it works perfectly fine. Is this is a known issue in OTM (v55-CU03)? If not, any tips on getting this work would be of great help. Thanks in advance.

  • #2
    Re: Error in Tender Response Integration

    Hello - Any support in this regard is greatly appreciated.

    Comment


    • #3
      Re: Error in Tender Response Integration

      Hi Raj,

      Could you please share with us the Tender Response XML. We tried to create the XML from the GLOGXML.xsd but it is not getting uploaded. Please share with us teh steps to get the tender response xml.
      Divya Bhansali

      Comment


      • #4
        Re: Error in Tender Response Integration

        Hi Divya,

        Not sure, if you have already managed to extract the XML by now. I have created this from XSD and managed to upload it without issues.Regarding the original issue I have received a confirmation from OTM support that this issue was fixed in CU4.

        Thanks,
        Raj

        Comment


        • #5
          Re: Error in Tender Response Integration

          I have also been trying to get the TenderResponse xml to load into OTM 5.0 without any success. The logs is trying to 'Perform action Classify Tender Response' and then the error appears:

          java.lang.NullPointerException
          at glog.server.workflow.tender.ProcessTenderResponse$ ClassifyTenderResponse.perform

          Most likely the XML format is missing a tag but while looking at OTM 5.0 XSD I seem to not been able to find it. Any help with anyone using the TenderResponse XML would be greatly appreciated or if anyone else has received this same issue.

          Thanks,
          Attached Files
          Last edited by bfolan; July 29, 2009, 16:49.

          Comment

          Working...
          X