Announcement

Collapse
No announcement yet.

Common Issue: Wrong WebLogic Version

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Common Issue: Wrong WebLogic Version

    Talking with my friends in support, a common issue a lot of clients are hitting is installing the wrong version of WebLogic. Unfortunately, OTM / GC3 is VERY particular about which versions of WebLogic it will work with.

    The most common scenario is that a client will install WebLogic 8.1 SP5 (UPDATE: BEA's default version is now 8.1 SP6) for use with OTM / GC3 v5.x, because this is the version that BEA has available for download. Unfortunately, this won't startup correctly and you'll get errors when trying to startup WebLogic that look like the following in the console.log or weblogic.log files:

    (BTW, thank you Shells for providing the error I'm using in this example!)

    Code:
    <Loading domain configuration from configuration repository at /opt/gc3v50/weblogic/config/gc3domain/./config.xml.>
    INFO  | jvm 1  | 2006/06/20 07:27:34 | ***************************************************************************
    INFO  | jvm 1  | 2006/06/20 07:27:34 | The WebLogic Server did not start up properly.
    INFO  | jvm 1  | 2006/06/20 07:27:34 | Exception raised: 'weblogic.management.configuration.ConfigurationException: - with nested exception:
    INFO  | jvm 1  | 2006/06/20 07:27:34 | [java.lang.ClassCastException: java.lang.NoClassDefFoundError]'
    INFO  | jvm 1  | 2006/06/20 07:27:34 | Reason: weblogic.management.configuration.ConfigurationException: - with nested exception:
    INFO  | jvm 1  | 2006/06/20 07:27:34 | [java.lang.ClassCastException: java.lang.NoClassDefFoundError ]
    INFO  | jvm 1  | 2006/06/20 07:27:34 | ***************************************************************************
    INFO  | jvm 1  | 2006/06/20 07:27:36 | JNDI naming exception:javax.naming.NoInitialContextException: JNDI subsystem is not ready for use
    INFO  | wrapper | 2006/06/20 07:27:36 | Waiting to start...
    INFO  | wrapper | 2006/06/20 07:27:41 | Waiting to start...
    ...
    INFO  | wrapper | 2006/06/20 07:28:37 | Waiting to start...
    ERROR | wrapper | 2006/06/20 07:29:39 | Shutdown failed: Timed out waiting for signal from JVM.
    ERROR | wrapper | 2006/06/20 07:29:39 | JVM did not exit on request, terminated
    STATUS | wrapper | 2006/06/20 07:29:39 | <-- Wrapper Stopped
    In order to resolve this issue, you first need to get the correct version of WebLogic by contacting BEA's support department and requesting access to previous releases - specifically WebLogic Server 8.1 SP4 (service pack 4).

    Then you can either:

    Re-install everything from scratch (recommended):
    1) Delete and re-install WebLogic
    2) Delete and re-install OTM / GC3

    or

    Update your existing installation to work correctly:
    1) Delete and re-install WebLogic
    2) Copy the files weblogic.jar and xmlx.jar from:
    <bea_home>/weblogic81/server/lib/
    to:
    <gc3_home>/glog/gc3webapp/lib/3rdparty/
    3) Copy gc3*.jar from:
    <gc3_home>/glog/gc3webapp/lib/3rdparty/
    to:
    <bea_home>/weblogic81/server/lib/mbeantypes/
    Note: Ensure that all of your file permissions and ownership are setup correctly.

    Hope this helps!

    --Chris
    Chris Plough
    twitter.com/chrisplough
    MavenWire
Working...
X