Announcement

Collapse
No announcement yet.

otmapp55 are having problems starting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • otmapp55 are having problems starting

    Hi,

    For those who have seen my last note: I have cleared everything out and made a fresh install. Everything was installed successful.

    However, I now get the following errors while trying to start the otmapp55 service:

    Error Exception Missing standard type COMMERCIAL_INVOICE_XID
    Error Exception Missing standard type COMMERCIAL_INVOICE_NUMBER
    Error Exception Missing standard type ROUTE_TEMPLATE_XID
    Error Exception Missing standard type ROUTE_TEMPLATE_LEG_XID
    Error Exception Missing standard type ROUTE_INSTANCE_XID
    Error Exception Missing standard type ROUTE_INSTANCE_LEG_XID
    Error Exception Missing standard type CR_ROUTE_TEMPLATE_XID_WITH_ROUTE

    All these also comes with this:
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstructorAccessorImpl.java:39)
    at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27)
    at java.lang.reflect.Constructor.newInstance(Construc tor.java:274)
    at glog.util.exception.GLException.factory(GLExceptio n.java:413)
    at glog.util.exception.GLException.factory(GLExceptio n.java:390)
    at glog.server.bngenerator.BNRuleLoader.checkStandard Types(BNRuleLoader.java:422)
    at glog.server.bngenerator.BNRuleLoader.readTypes(BNR uleLoader.java:92)
    at glog.server.bngenerator.BNRuleLoader.loadData(BNRu leLoader.java:35)
    at glog.util.DataLoader.load(DataLoader.java:19)
    at glog.util.StartupShutdownManager.load(StartupShutd ownManager.java:76)
    at glog.util.StartupShutdownManager.load(StartupShutd ownManager.java:60)
    at glog.util.StartupShutdownManager.load(StartupShutd ownManager.java:56)
    at glog.util.j2ee.startup.OASStartupShutdownManager.p ostDeploy(OASStartupShutdownManager.java:41)
    at com.evermind.util.ClassDescriptor.executeStartupCl ass(ClassDescriptor.java:75)
    at com.evermind.server.ApplicationServer.execStartupC lassesPostDeploy(ApplicationServer.java:130
    at com.evermind.server.ApplicationServer.setConfig(Ap plicationServer.java:926)
    at com.evermind.server.ApplicationServerLauncher.run( ApplicationServerLauncher.java:113)
    at java.lang.Thread.run(Thread.java:534)

    In addition, I also get the following:
    Error Exception Unknown service: SecuritySessionHome
    javax.naming.NameNotFoundException: SecuritySessionHome not found
    at com.evermind.server.rmi.RMIServerContext.lookup(RM IServerContext.java:202)
    at com.evermind.server.ApplicationContext.unprivilege d_lookup(ApplicationContext.java:259)
    at com.evermind.server.ApplicationContext.lookup(Appl icationContext.java:199)
    at com.evermind.naming.FilterContext.lookup(FilterCon text.java:126)
    at com.evermind.server.PreemptiveApplicationContext.l ookup(PreemptiveApplicationContext.java:42)
    at javax.naming.InitialContext.lookup(InitialContext. java:347)
    at glog.util.remote.NamingDirectory.lookupContext(Nam ingDirectory.java:652)
    at glog.util.remote.NamingDirectory.lookup(NamingDire ctory.java:612)
    at glog.util.remote.SessionBeanHomeInvoker.<init>(Ses sionBeanHomeInvoker.java:27)
    at glog.util.remote.NamingDirectory.get(NamingDirecto ry.java:170)
    at glog.util.remote.NamingDirectory.get(NamingDirecto ry.java:225)
    at glog.util.remote.NamingDirectory.get(NamingDirecto ry.java:241)
    at glog.util.remote.NamingDirectory.impersonateSecuri ty(NamingDirectory.java:371)
    at glog.server.workflow.WorkflowManager.execute(Workf lowManager.java:323)
    at glog.server.workflow.Trigger.trigger(Trigger.java: 111)
    at glog.util.event.MemoryEventQueueRunnable.processEv ent(MemoryEventQueueRunnable.java:141)
    at glog.util.event.MemoryEventQueueRunnable.run(Memor yEventQueueRunnable.java:96)
    at glog.util.event.EventThread.run(EventThread.java:7 9)
    at java.lang.Thread.run(Thread.java:534)

    Does anyone know where to start looking for error in the configuration or setup? Or if anyone know how to solve these issues, I would be more than happy

    Thanks,
    Niclas

  • #2
    Re: otmapp55 are having problems starting

    Niclas,

    Can you remind me what version of OTM you installed? Was it v5.5 CU3? I ask because some of these issues (ex. Error Exception Missing standard type COMMERCIAL_INVOICE_XID) concern me and I haven't seen them before. I may have some free time tomorrow to help you troubleshoot, if you could upload the following:
    • <otm_home_dir>/Oracle_OTM_v5.5_*.xml
    • <otm_home_dir>/glog/oracle/export/*.log
    • <otm_home_dir>/glog/oracle/script8/*.log
    • <otm_home_dir>/logs/weblogic/console.log
    Note: Please zip up before uploading to save space on our forum servers

    Thanks!
    --Chris
    Chris Plough
    twitter.com/chrisplough
    MavenWire

    Comment


    • #3
      Re: otmapp55 are having problems starting

      Chris,
      we run into the same issue after applying CPUOct2007 to OAS.
      version v5.5CU3. Not additional patch.
      some of the errors are SecuritySessionHome not found,
      unknow service: workflow.WorkflowSession.Transactional not found.

      We un-installed the patch, deleted the gc3deployNN directory, even changed the GC3App.ear's timestamp, hope OAS will load the bean, jar file as fresh start.
      But the problem persists.

      Thanks for help!

      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 javax.naming.NameNotFoundException: SecuritySessionHome not found
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at com.evermind.server.rmi.RMIServerContext.lookup(RM IServerContext.java:20
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at com.evermind.server.ApplicationContext.unprivilege d_lookup(ApplicationContext.java:259)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at com.evermind.server.ApplicationContext.lookup(Appl icationContext.java:199)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at javax.naming.InitialContext.lookup(InitialContext. java:347)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.remote.NamingDirectory.lookupContext(Nam ingDirectory.java:652)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.remote.NamingDirectory.lookup(NamingDire ctory.java:612)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.remote.SessionBeanHomeInvoker.<init>(Ses sionBeanHomeInvoker.java:27)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.remote.NamingDirectory.get(NamingDirecto ry.java:170)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.remote.NamingDirectory.get(NamingDirecto ry.java:225)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.remote.NamingDirectory.get(NamingDirecto ry.java:241)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.remote.NamingDirectory.impersonateSecuri ty(NamingDirectory.java:371)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.server.workflow.WorkflowManager.execute(Workf lowManager.java:323)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.server.workflow.Trigger.trigger(Trigger.java: 111)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.event.MemoryEventQueueRunnable.processEv ent(MemoryEventQueueRunnable.java:141)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.event.MemoryEventQueueRunnable.run(Memor yEventQueueRunnable.java:96)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at glog.util.event.EventThread.run(EventThread.java:7 9)
      INFO | jvm 1 | 2007/10/31 11:28:00 | 07/10/31 11:28:00 at java.lang.Thread.run(Thread.java:534)
      INFO | jvm 1 | 2007/10/31 11:29:00 | 07/10/31 11:29:00 Unknown service: SecuritySessionHome
      INFO | jvm 1 | 2007/10/31 11:29:00 | javax.naming.NameNotFoundException: SecuritySessionHome not found

      Comment


      • #4
        Re: otmapp55 are having problems starting

        Unfortunately, I'm not sure that many of these CPU patches are tested by the OTM team, as it uses a customized version of OAS internally. The fastest solution is just to reinstall the OTM app server and point it against your existing database.

        Can you update us on the response you received from Oracle Support and how you resolved the issue?

        Thanks,
        Chris
        Chris Plough
        twitter.com/chrisplough
        MavenWire

        Comment


        • #5
          Re: otmapp55 are having problems starting

          I run into this problem too. What we did is uninstall the patch, AND remove some of the jar files from OAS installed by the patch, automatic uninstall still leave these jar files there, you need to manually delete them.

          The OTM dev team indicated that CU4 of OTM should resolve this issue. Let's see if this is the case.

          Comment


          • #6
            Re: otmapp55 are having problems starting

            Hi, chrisplough:
            I have just completed my first installation of OTM 5.5.5 on our test server(web\app\database in single server). Most of the installation steps went smoothly.

            abnormity:
            1、
            ..
            ownload the following file into a temporary directory:
            a. SourceForge.net: Downloading ...
            ....
            The connect is otiose.
            so i'am download wsdl4j-1.5.1.jar (rename to wsdl4j.jar).

            2、The FinJ don't install because SourceForge.net: Downloading ... is otiose too.

            3、The tablespace content is specify in oracle em.(http://localhost:1158/em)

            log.zip :
            <otm_home_dir>/Oracle_OTM_v5.5_*.xml
            <otm_home_dir>/glog/oracle/export/*.log
            <otm_home_dir>/glog/oracle/script8/*.log
            <otm_home_dir>/logs/weblogic/console.log


            help me, please
            thank you very much.
            (my english is pool -_-)
            Attached Files

            Comment


            • #7
              Re: otmapp55 are having problems starting

              Originally posted by chrisplough View Post
              Niclas,

              Can you remind me what version of OTM you installed? Was it v5.5 CU3? I ask because some of these issues (ex. Error Exception Missing standard type COMMERCIAL_INVOICE_XID) concern me and I haven't seen them before. I may have some free time tomorrow to help you troubleshoot, if you could upload the following:
              • <otm_home_dir>/Oracle_OTM_v5.5_*.xml
              • <otm_home_dir>/glog/oracle/export/*.log
              • <otm_home_dir>/glog/oracle/script8/*.log
              • <otm_home_dir>/logs/weblogic/console.log
              Note: Please zip up before uploading to save space on our forum servers

              Thanks!
              --Chris


              Hi, chrisplough:
              I have just completed my first installation of OTM 5.5.5 on our test server(web\app\database in single server). Most of the installation steps went smoothly.
              abnormity :
              1、
              ..
              ownload the following file into a temporary directory:
              a. SourceForge.net: Downloading ...
              ....
              The connect is otiose.
              so i'am download wsdl4j-1.5.1.jar (rename to wsdl4j.jar).

              2、The FinJ don't install because SourceForge.net: Downloading ... is otiose too.

              3、The tablespace content is specify in oracle em.(http://localhost:1158/em)

              now, i visit Glog( http://localhost ) appear erro:

              log.zip :
              <otm_home_dir>/Oracle_OTM_v5.5_*.xml
              <otm_home_dir>/glog/oracle/export/*.log
              <otm_home_dir>/glog/oracle/script8/*.log
              <otm_home_dir>/logs/weblogic/console.log

              + glog.exception.log

              help me, please
              thank you very much.
              (my english is pool -_-)
              Attached Files

              Comment


              • #8
                Re: otmapp55 are having problems starting

                DavidLi,

                Just looking at your exception log it appears that you are missing columns from your database tables. Did your import of the database complete successfully? Were the post database scripts executed as per the admin guide? Did you also patch the database to the service release you installed after you imported it?

                Nick
                If my post was helpful please click on the Thanks! button

                MavenWire Hosting Admin
                15 years of OTM experience

                Comment


                • #9
                  Re: otmapp55 are having problems starting

                  nick,
                  First, thanks for your help. I'm sure that the import of the database is successful. I work out it complete according to the admin guide, but when executed the following i made a mistake,
                  because i haven't found <otm_install_path>/gc3/glog/oracle directory, i executed @insert_security_roles.sql in the <otm55_install_path>/glog/oracle directory.

                  from admin guide:
                  Setup Security Roles
                  1. Change to the <otm_install_path>/gc3/glog/oracle directory on the Oracle Transportation
                  Management Application server.
                  2. In SQL*Plus as the GLOGOWNER user, run:
                  @insert_security_roles.sql
                  Migrate the New Database
                  You must now migrate the new database to the CU3 structure:
                  Open up a shell (UNIX) or command prompt (Windows) on the APP server
                  Copyright © 2001, 2008, Oracle. All rights reserved. 3-25
                  Important: Ensure that your environment is setup correctly by running:
                  On UNIX: “. <otm_install_path>/install/gc3env.sh”
                  On Win32: “<otm_install_path>\install\gc3env.cmd”
                  Change directory to <otm55_install_path>/glog/oracle/script8
                  In SQL*Plus as user GLOGOWNER, run:
                  @dbpatch_55.sql
                  Enter the passwords and connection strings when prompted
                  Check the log files (dbpatch log and update_content log) to ensure they are error free before
                  proceeding to the next step
                  Change directory to <otm55_install_path>/glog/oracle
                  In SQL*Plus as user GLOGOWNER, run:
                  @insert_security_roles.sql


                  I haven't made other mistakes except above.

                  Thanks again.

                  davidli.

                  Comment


                  • #10
                    Re: otmapp55 are having problems starting

                    Please post the console.log file from your <<otm install directory>>/logs/weblogic and I'll see if I can help.
                    If my post was helpful please click on the Thanks! button

                    MavenWire Hosting Admin
                    15 years of OTM experience

                    Comment


                    • #11
                      Re: otmapp55 are having problems starting

                      Originally posted by nick.polites View Post
                      Please post the console.log file from your <<otm install directory>>/logs/weblogic and I'll see if I can help.
                      Nick,
                      The console.log file in attach files.

                      thanks.
                      Attached Files

                      Comment


                      • #12
                        Re: otmapp55 are having problems starting

                        Nick,
                        In fact, the console.log file is among the log.zip that has been already uploaded to the forum.

                        Best wishes!
                        davidli.

                        Comment


                        • #13
                          Re: otmapp55 are having problems starting

                          Here is your problem...


                          INFO | jvm 1 | 2008/07/23 16:47:45 | <2008-7-23 ÏÂÎç04ʱ47·Ö45Ãë CST> <Notice> <Security> <BEA-090078> <User guest in security realm gc3realm has had 5 invalid login attempts, locking account for 30 minutes.>
                          INFO | jvm 1 | 2008/07/23 16:47:45 | [memory ] 590.289: nursery GC 416882K->408221K (1049600K), 83.880 ms
                          INFO | jvm 1 | 2008/07/23 16:48:00 | <2008-7-23 ÏÂÎç04ʱ48·Ö00Ãë CST> <Critical> <Security> <BEA-090403> <Authentication for user guest denied>
                          INFO | jvm 1 | 2008/07/23 16:48:00 | javax.security.auth.login.LoginException: javax.security.auth.login.LoginException: java.lang.SecurityException: 090403
                          INFO | jvm 1 | 2008/07/23 16:48:00 |
                          INFO | jvm 1 | 2008/07/23 16:48:00 | javax.security.auth.login.LoginException: javax.security.auth.login.LoginException: java.lang.SecurityException: 090403
                          INFO | jvm 1 | 2008/07/23 16:48:00 | at glog.database.security.jaas.ClientLoginModuleImpl. login(ClientLoginModuleImpl.java:50)



                          Unfortunatly I don't know why the guest authentication is failing. Can you run a sql query and see if it returns? Paste the results in the forum. Select * from gl_user where gl_user_gid='guest';
                          If my post was helpful please click on the Thanks! button

                          MavenWire Hosting Admin
                          15 years of OTM experience

                          Comment


                          • #14
                            Re: otmapp55 are having problems starting

                            Originally posted by nick.polites View Post
                            Here is your problem...


                            INFO | jvm 1 | 2008/07/23 16:47:45 | <2008-7-23 ÏÂÎç04ʱ47·Ö45Ãë CST> <Notice> <Security> <BEA-090078> <User guest in security realm gc3realm has had 5 invalid login attempts, locking account for 30 minutes.>
                            INFO | jvm 1 | 2008/07/23 16:47:45 | [memory ] 590.289: nursery GC 416882K->408221K (1049600K), 83.880 ms
                            INFO | jvm 1 | 2008/07/23 16:48:00 | <2008-7-23 ÏÂÎç04ʱ48·Ö00Ãë CST> <Critical> <Security> <BEA-090403> <Authentication for user guest denied>
                            INFO | jvm 1 | 2008/07/23 16:48:00 | javax.security.auth.login.LoginException: javax.security.auth.login.LoginException: java.lang.SecurityException: 090403
                            INFO | jvm 1 | 2008/07/23 16:48:00 |
                            INFO | jvm 1 | 2008/07/23 16:48:00 | javax.security.auth.login.LoginException: javax.security.auth.login.LoginException: java.lang.SecurityException: 090403
                            INFO | jvm 1 | 2008/07/23 16:48:00 | at glog.database.security.jaas.ClientLoginModuleImpl. login(ClientLoginModuleImpl.java:50)



                            Unfortunatly I don't know why the guest authentication is failing. Can you run a sql query and see if it returns? Paste the results in the forum. Select * from gl_user where gl_user_gid='guest';
                            The query results in the attach files.(gl_user.txt)
                            My oracle's technology is poor, the results's format is not good.

                            Best Wishes!
                            davidli.
                            Attached Files
                            Last edited by davidli; July 24, 2008, 07:46.

                            Comment


                            • #15
                              Re: otmapp55 are having problems starting

                              Update the password to VAU9uZtJtMwEb3tIVKgN49bfrnE= and then restart the application. You should get past this error after that.

                              Someone must have ran a mass update on the password. This is generally a bad idea without knowing what you need to update.

                              Also update the account lockout if it is indeed locked out.
                              Last edited by nick.polites; July 23, 2008, 15:06.
                              If my post was helpful please click on the Thanks! button

                              MavenWire Hosting Admin
                              15 years of OTM experience

                              Comment

                              Working...
                              X