Announcement

Collapse
No announcement yet.

OTM 5.5 CU05 with Oracle RAC

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OTM 5.5 CU05 with Oracle RAC

    Hi,

    I am currently installing OTM 5.5 CU05 under the following environment:

    Application / Web Servers : RedHat AS 4.7 64bit
    Oracle Database: 10.2.0.3 Solaris 64bit RAC

    The issue that I have hit is while running dbpatch_55.sql update_content.sh fails with the following stack trace:

    java.sql.SQLException: Io exception: The Network Adapter could not establish the connection
    at oracle.jdbc.driver.DatabaseError.throwSqlException (DatabaseError.java:112)
    at oracle.jdbc.driver.DatabaseError.throwSqlException (DatabaseError.java:146)
    at oracle.jdbc.driver.DatabaseError.throwSqlException (DatabaseError.java:255)
    at oracle.jdbc.driver.T4CConnection.logon(T4CConnecti on.java:387)
    at oracle.jdbc.driver.PhysicalConnection.<init>(Physi calConnection.java:439)
    at oracle.jdbc.driver.T4CConnection.<init>(T4CConnect ion.java:165)
    at oracle.jdbc.driver.T4CDriverExtension.getConnectio n(T4CDriverExtension.java:35)
    at oracle.jdbc.driver.OracleDriver.connect(OracleDriv er.java:801)
    at java.sql.DriverManager.getConnection(DriverManager .java:512)
    at java.sql.DriverManager.getConnection(DriverManager .java:171)
    at glog.database.admin.CSVUtil.initializeConnection(C SVUtil.java:279
    at glog.database.admin.CSVUtil.run(CSVUtil.java:2689)
    at glog.database.admin.CSVUtil.main(CSVUtil.java:3017 )

    The modifications that I have made to glog.properties are as follows:

    # db server URL and information
    #dbserver=
    #glog.database.sid=
    #glog.database.connectstring=
    #glog.database.port=

    glog.database.dbaOnly.t2client.connectionURL=jdbcracle:thin:@(DESCRIPTION=(ADDRESS_LIST=(LOAD_BALAN CE=off)(ADDRESS=(PROTOCOL=TCP)(HOST=atsdbdod01.tol l.com.au)(PORT=1599))(ADDRESS=(PROTOCOL=TCP)(HOST = atsdbdod02.toll.com.au)(PORT = 1599)))(CONNECT_DATA = (service_name= TGFNODE1)))
    glog.database.dbathin.t2client.connectionURL=$glog .database.dbaOnly.t2client.connectionURL$
    glog.database.DBA.t2client.connectionURL=$glog.dat abase.dbaOnly.t2client.connectionURL$
    glog.database.DBADirect.t2client.connectionURL=$gl og.database.dbaOnly.t2client.connectionURL$
    glog.database.migration.t2client.connectionURL=$gl og.database.dbaOnly.t2client.connectionURL$

    I have tested the connection url through SQL Developer and it works fine. It seems that glog.database.admin.CVSUtil is trying to use commented out properties to build the jdbc connection string. Is that correct? How do we get it to use the connection url?

    I would imagine that it is something simple but any help would be greatly appreciated.

    Cheers,
    --oli

  • #2
    Re: OTM 5.5 CU05 with Oracle RAC

    Are you running the DB scripts from the application server? Please revert the changes you made to glog.database.dbaOnly.t2client.connectionURL as this file never needs to be modified.
    If my post was helpful please click on the Thanks! button

    MavenWire Hosting Admin
    15 years of OTM experience

    Comment


    • #3
      Re: OTM 5.5 CU05 with Oracle RAC

      Hi,

      Yes I am running the scripts from the Application server.

      I will comment out the line that you suggested.

      I did notice that because glog.database.sid is not set it is defaulting to localdb. Is this the correct behavior?

      Is there any documentation available for configuring OTM with Oracle RAC? Other than the half page that is in the Administration guide I should add :-)

      Cheers,
      --oli

      Comment


      • #4
        Re: OTM 5.5 CU05 with Oracle RAC

        It should be pulling off of your glog.properties with the database information that is in there. If it isn't then there is some other issue going on as long as that information is correct.
        If my post was helpful please click on the Thanks! button

        MavenWire Hosting Admin
        15 years of OTM experience

        Comment


        • #5
          Re: OTM 5.5 CU05 with Oracle RAC

          Cool... so just to clarify. In the case of setting the glog.properties file for Oracle RAC. The following settings are not used:

          dbserver
          glog.database.sid
          glog.database.connectstring
          glog.database.port

          And are pulled from:

          glog.database.dbathin.t2client.connectionURL
          glog.database.DBA.t2client.connectionURL
          glog.database.DBADirect.t2client.connectionURL
          glog.database.migration.t2client.connectionURL

          Is there another variable that needs to be set to force the change? I ask this because glog.database.admin.CVSUtil is definitely using dbserver, glog.database.sid and glog.database.port. If I set them to one of our other OTM databases and use a invalid username/password then I just get invalid username errors.

          This is the first OTM installation that we have tried against Oracle RAC.

          Sorry one other thing that I should point out is that I am just running update_connect.sh from the shell after doing . gc3env.sh. This is just to save time repeatly running dbpatch_55.sql.

          Thanks,
          --oli

          Comment


          • #6
            Re: OTM 5.5 CU05 with Oracle RAC

            I think you may have to contact Oracle support on this. I know that the CSVUtil uses the default database connection parameters. I bet if you uncommented those out and put in the SID you should be able to get the db patch to install.
            If my post was helpful please click on the Thanks! button

            MavenWire Hosting Admin
            15 years of OTM experience

            Comment


            • #7
              Re: OTM 5.5 CU05 with Oracle RAC

              Oli,

              BTW - this was one of the issues I used to run into at G-Log when I was testing out RAC with OTM v4.0. I thought this would have been resolved by now - but am not sure exactly what's been done.

              Can you post back with your learnings from support?

              --Chris
              Chris Plough
              twitter.com/chrisplough
              MavenWire

              Comment

              Working...
              X