Announcement

Collapse
No announcement yet.

Integrating OTM55 CU3 with Oracle Report Server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Integrating OTM55 CU3 with Oracle Report Server

    Hi everyone,

    I have installed OTM55 CU3 on Windows Server 2003.
    Also,I have installed Oracle Report Server on the same machine as OTM but in a different drive.

    Now is there a way to integrate the installed Report Server with the existing OTM instance?Or do I need to reinstall the OTM again choosing "Web,App and Report Server" option?

    I appreciate any information.

    Thanks in advance,
    Durga

  • #2
    Re: Integrating OTM55 CU3 with Oracle Report Server

    Durga,

    The OTM Reports tier is made up of 2 components -- the Oracle Reports Server (OAS) and the OTM Reports installation. Both of these need to be present and configured for the feature to work.

    You have 2 options:

    1) The simplest is to re-install OTM using the "Web, App and Report Server" option.

    2) Alternately, you can install the OTM "Report Server" option into a separate directory and then integrate it back with the existing OTM installation (just as you would if they existed on separate servers). If you do this, though, you'll need to apply any future patches to both directories to ensure they're at the same patch level.

    --Chris
    Chris Plough
    twitter.com/chrisplough
    MavenWire

    Comment


    • #3
      Re: Integrating OTM55 CU3 with Oracle Report Server

      Mr.Chris,

      Thanks for your prompt reply.

      I reinstalled OTM with all the Web,App and Reports components selected.
      After the installation is done,i see only 3 services(otmweb55 is missing) listed out.
      I started all the 3 services(otmapp55,otmwebtomcat55,otmwebrpt55),when I hit the URL
      http://OTM_Host_Name, it is directing to ReportServer page.I am not getting the OTM Login page.

      During the installation,I configured "Web Server Port = 80","Report Apache Port=81" and remaining ports to 7001,1521 etc...

      I think the problem is with the Report Server installation,where in I have accepted the default values for the ports information.So I tried uninstalling Report Server.But it is failing during uninstallation.

      Any suggestions pls..

      Thanks,
      Durga

      Comment


      • #4
        Re: Integrating OTM55 CU3 with Oracle Report Server

        I'm not sure what is failing during your uninstallation -- that may take Oracle support to resolve. When you re-install, though, you should force the Oracle Reports port mapping. You'll find directions here:

        http://www.otmfaq.com/forums/f23/ins...t-mapping-360/

        --Chris
        Chris Plough
        twitter.com/chrisplough
        MavenWire

        Comment


        • #5
          Re: Integrating OTM55 CU3 with Oracle Report Server

          Mr.Chris,

          Thanks for your reply.
          I cudn't uninstall the first reports instance.So created a new instance and reinstalled OTM choosing the Report Server option.

          Installation is successful.After starting all the services,when I try to generate a report,I got the following error.

          REP-51002: Bind to Reports Server rep_hydhtc137458d_frhome2.DomainName failedThe entries in the glog.properties are as follows# external Oracle Reports Server - optional
          report_feature=true
          p_reports_server=REP_HYDHTC137458D_FRHOME2.DomainN ame
          p_reports_out_dir=D:/OTM55/rptapache/htdocs
          reports_server_fqdn=http://hydhtc137458d.DomainName:7777/reports/rwservlet
          report_server_url=http://hydhtc137458d.DomainName:81
          #discoverer_url=Any suggestions pls..Thanks,
          Durga

          Comment


          • #6
            Re: Integrating OTM55 CU3 with Oracle Report Server

            Pull up your emconsole and make sure that the report instance name appears REP_HYDHTC137458D_FRHOME2.DomainN ame as what is in your glog.properties. Also be sure your hide_pass_key has been added to your cgicmd.dat file and you have updated your reports properties instance as per the admin guide.
            If my post was helpful please click on the Thanks! button

            MavenWire Hosting Admin
            15 years of OTM experience

            Comment

            Working...
            X