Announcement

Collapse
No announcement yet.

Turn off automatic uppercasing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Turn off automatic uppercasing

    Hi folks,

    OTM changes a lot of fields to uppercase upon entry. While I can accept that for domain names and the like, it is more then annoying with e.g address lines for location addresses. The system should not change the data it is supposed to store, and if the user chose to enter an address in a legible form instead OF SHOUTING ALL IN UPPERCASE, there might be a reason to do so.

    Does anyone know how to get rid of this "feature"? I did not find anything appropriate in neither the documentation nor the various .properties files (only for an integration feature). I therefore post this in the Screens forum, since it is the JavaScript code doing the case change.

    Any help would be greatly appreciated.

    Regards
    Sven

  • #2
    Re: Turn off automatic uppercasing

    Hi Sven

    I think you'll find that there is no way to turn it off - and its there for a very good reason.

    Searching in OTM is case sensative, so unless this standard is imposed - you'd never find anything.

    Cheers
    Gary
    Regards
    Gary Cunningham
    www.cbmc.co.uk
    www.mavenwire.com

    Comment


    • #3
      Re: Turn off automatic uppercasing

      Hi Sven,
      There are certain fields in OTM where it will display as entered instead of changing to UPPERCASE like searching Assign functions with a Level, Sub menu names in a Menu,Tranlation Manager, etc. Try to figure out which template in XSL is being used for those text area and investigate if any parameter is associated in its template definition in xsls ('Fields.xsl' or 'Style.xsl' i forgot).
      So that you can get an idea like why the javascript is not enabled or applicable to those columns.

      Cheers,
      neoandr
      Cheers,
      -Neo

      Comment


      • #4
        Re: Turn off automatic uppercasing

        As Gary has mentioned the reason why everything is in uppercase is for searching reasons and has been coded that way. If you go hacking the xsl stylesheets there could be code which may cause a problem and not return the results that you expect.

        If you look at Dell invoices, shipping labels etc most of them are in uppercase for that reason.
        If my post was helpful please click on the Thanks! button

        MavenWire Hosting Admin
        15 years of OTM experience

        Comment


        • #5
          Re: Turn off automatic uppercasing

          Originally posted by nick.polites View Post
          As Gary has mentioned the reason why everything is in uppercase is for searching reasons and has been coded that way. If you go hacking the xsl stylesheets there could be code which may cause a problem and not return the results that you expect.

          If you look at Dell invoices, shipping labels etc most of them are in uppercase for that reason.
          Gary, Nick, thank you for that valuable background information.

          Hmm, so instead of fixing the search function someone decided to change the actual data to compare against? Not a very good design choice, I must say.

          To illustrate the point, if you go beyond the US-ASCII world, you are very quickly out of luck. For example, the (common) German name "Herr Groß" becomes "HERR GROSS" in uppercase. The same holds true for street names, e.g. "Große Bleiche" is "GROSSE BLEICHE". The reason is that no uppercase letter exists for the German ß (eszett). Having people (or machines) without a German background to judge if "Groß" is identical to "GROSS", even if the number of characters is already different, is a not very reliable process.

          I am sure similar cases exist in other languages.

          So, in summary, in our global setting we cannot accept a system that makes its own changes to our address data. We will either have to change that behaviour on our own, or even better, have Oracle fix that bug.

          Comment


          • #6
            Re: Turn off automatic uppercasing

            turnoff of uppercasing is possibile thru a change in the properties file, I think u can find it in the properties file.

            rgds


            Ravee
            Regards,


            Raveendranath Thalapalli

            Comment


            • #7
              Re: Turn off automatic uppercasing

              If you can post the property that would help the group. As far I can find, the only thing that you can restrict from uppercase is integration elements.
              If my post was helpful please click on the Thanks! button

              MavenWire Hosting Admin
              15 years of OTM experience

              Comment


              • #8
                Re: Turn off automatic uppercasing

                Hi,

                I correct myself that Change Case is possible for integration only at Common Properties section in the properties file under glog.integration.EnableCaseChange option.

                Regret inconvenience.

                rgds

                Ravee
                Regards,


                Raveendranath Thalapalli

                Comment


                • #9
                  Re: Turn off automatic uppercasing

                  Hi,

                  This can be possible thru Manager Layouts. You can select required fields to see "as entered" and save the manager layout, then it displays "as is".

                  Thanks,
                  Lakshmi

                  Comment


                  • #10
                    Re: Turn off automatic uppercasing

                    I tried with manager layouts with check box "As Entered" but it did not work. It changed small case characters to upper case...
                    I found that this check box option works for UOM.
                    For clear understanding, 'As Entered' is for non-conversion of UOM according to user preferences and maintains the same UOM ,as entered, across all users.

                    Please correct me if i am wrong

                    Cheers!
                    Cheers,
                    -Neo

                    Comment


                    • #11
                      Re: Turn off automatic uppercasing

                      Hi

                      When you create a manager layout, you can edit a specific field. There is an option called 'Allow Mixed Case' which you can turn on or off. That way, your data will not automatically be converted to CAPS.

                      This change can also be done in the JSPX file using mixedCase="false"

                      Hope this helps.

                      Rajashree
                      Last edited by Rajashree; June 3, 2008, 11:31.

                      Comment

                      Working...
                      X