Hello all,

We discovered that on OTM 5.0, if you build a saved query from one of the Shipment Manager and use "White Circle" as the search criterion, the query that actually gets written looks for the SHIPMENT.INDICATOR field to be null. This works fine normally, because null indicators are the inital state for shipment indicators and they show up as the White Circle to the user. I've got some more detail on the problem and a work-around here.

PROBLEM DETAILS:
If you have an agent flipping indicators to other colors based on some events, and the indicator flips to a value of 'W' based on some event, you're headed for trouble if the users search on their indicators. If you select 'W', the agent will set the SHIPMENT.INDICATOR field to 'W' rather than null. Then there is no way for the user to search for this data because it's impossible to search for shipments where SHIPMENT.INDICATOR = 'W'. The really weird thing about trying to trouble shoot one of these is that in the UI, indicators with values of 'W' and null look exactly the same to the user, so they cannot usually tell why "white circle searches" bring back 99% of their shipments, but a few sneak under the radar because of this.

I have a support ticket in on this (5965297.993) and development deemed this something that needed to be code-fixed but support said they were omitting this from the Oracle knowledgebase because it was specific to TLC. I disagree with that. I know of other clients of OTM that use indicators and could have instances when they want to flip a shipment back to 'W'. It's a very common practice so I decided to write a post.

WORKAROUND:
The work-around for this is to set the indicators back to null if you want them to appear as the White Circle to the user. This can be done by selecting the blank row in the agent's action tab where you can select 'R', 'Y', 'G' or 'W'...there is another row in that selector box with no value on it. If you use that, it sets it to null.

-TL