Announcement

Collapse
No announcement yet.

Getting error while doing the Assign Rate action for a shipment

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting error while doing the Assign Rate action for a shipment

    I am getting below error while doing the Assign Rate action for a shipment:

    "Failed to assign service provider while assigning rate for shipment/Error_Recalculate_Shipment_Cost"

    As far a i know assign rate function assigns the least cost available for the current service provider of the shipment, but here it is getting failed to assign service provider.

    Can anyone please let me know the possible cause for this.

  • #2
    Re: Getting error while doing the Assign Rate action for a shipment

    I am using OTM V5.5 and the detailed error message is below:

    Failed to assign service provider while assigning rate for shipmentFailed to assign service provider while assigning rate for shipment/Error_Recalculate_Shipment_Cost at sun.reflect.GeneratedConstructorAccessor488.newIns tance(Unknown Source) at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27) at java.lang.reflect.Constructor.newInstance(Construc tor.java:282) at glog.util.exception.GLException.factory(GLExceptio n.java:413) at glog.util.exception.GLException.factory(GLExceptio n.java:390) at glog.business.action.helper.ShipmentPlanningAction Helper.assignShipmentRate(ShipmentPlanningActionHe lper.java:1856) at glog.business.action.ShipmentPlanningActionExecuto r.assignShipmentRate(ShipmentPlanningActionExecuto r.java:734) at glog.business.action.ShipmentPlanningActionExecuto r.assignShipmentRates(ShipmentPlanningActionExecut or.java:650) at glog.business.session.ShipmentPlanningActionSessio nBean.assignShipmentRates(ShipmentPlanningActionSe ssionBean.java:361) at glog.business.session.ShipmentPlanningActionSessio nServerSideEJBWrapper.assignShipmentRates(Shipment PlanningActionSessionServerSideEJBWrapper.java:394 ) at glog.business.session.ShipmentPlanningActionSessio nServerSideEJBWrapper_7zfvrj_EOImpl.assignShipment Rates(ShipmentPlanningActionSessionServerSideEJBWr apper_7zfvrj_EOImpl.java:2854) at glog.business.session.gen.ShipmentPlanningActionSe ssionSkel.assignShipmentRates(ShipmentPlanningActi onSessionSkel.java:676) at glog.business.session.gen.ShipmentPlanningActionSe ssionSkel.exec(ShipmentPlanningActionSessionSkel.j ava:140) at glog.webserver.wrapper.SkelImpl.execDispatch(SkelI mpl.java:15) at glog.server.wrapper.WrapperSessionBean.execDispatc h(WrapperSessionBean.java:57) at glog.server.wrapper.WrapperSessionServerSideEJBWra pper.execDispatch(WrapperSessionServerSideEJBWrapp er.java:42) at glog.server.wrapper.WrapperSessionHome_a06097_EOIm pl.execDispatch(WrapperSessionHome_a06097_EOImpl.j ava:46) at glog.server.wrapper.WrapperSessionHome_a06097_EOIm pl_WLSkel.invoke(Unknown Source) at weblogic.rmi.internal.BasicServerRef.invoke(BasicS erverRef.java:491) at weblogic.rmi.cluster.ReplicaAwareServerRef.invoke( ReplicaAwareServerRef.java:120) at weblogic.rmi.internal.BasicServerRef$1.run(BasicSe rverRef.java:434) at weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(AuthenticatedSubject.java:363) at weblogic.security.service.SecurityManager.runAs(Se curityManager.java:147) at weblogic.rmi.internal.BasicServerRef.handleRequest (BasicServerRef.java:429) at weblogic.rmi.internal.BasicExecuteRequest.execute( BasicExecuteRequest.java:35) at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:224) at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:183) [ExecuteThread: '33' for q]

    Comment


    • #3
      Re: Getting error while doing the Assign Rate action for a shipment

      Below 2 actions work differently

      Assign rate - similar to planning - finds best available rate among all valid service providers that meet all constraints - if nothing is found, it will error

      Recalculate cost - try to recalculate shipment cost for the same (assigned) service provider only - generally used if rate record is changed after shipment planning and we want shipment cost to be recalculated based on new rate definition for same service provider.

      Regards
      Nipun
      Nipun Lakhotia
      Manager, EY

      Comment


      • #4
        Re: Getting error while doing the Assign Rate action for a shipment

        Hi Nipun,

        Thanks for the reply, but Recalculate Shipment Cost is not changing either the rate record and cost value onto the shipment.

        I just tried planning the shipment having one rate record and later i expired the current one and create a new rate record with new cost value, then i did the recalculate shipment cost but the result is not as expected.

        Thanks,
        Anand

        Comment


        • #5
          Re: Getting error while doing the Assign Rate action for a shipment

          Recalculate cost works only with same rate record. If its new rate record (even with same service provider) - try assign rate action
          Nipun Lakhotia
          Manager, EY

          Comment


          • #6
            Re: Getting error while doing the Assign Rate action for a shipment

            That is where i am getting the above mentioned error while doing the assign rate. It is saying failed to assign the service provider while assigning the rate, but when i do the RIQ using the same data in the shipment i can get the valid rates that are available.

            So i need to know the exact cause for this error message.

            Comment


            • #7
              Re: Getting error while doing the Assign Rate action for a shipment

              Did you get reason for this? We are also facing same issue

              Comment


              • #8
                Re: Getting error while doing the Assign Rate action for a shipment

                Hi Vibhas,

                You need to find out the reason why your action is failing. For a similar failure message there can be multiple reasons.

                Enable RateEngine logs and scan through them if all the rules are passing?
                -------
                Thanks and Regards
                Anurag Saini
                MavenWire

                Comment


                • #9
                  Originally posted by nipunlakhotia View Post
                  Re: Getting error while doing the Assign Rate action for a shipment

                  Below 2 actions work differently

                  Assign rate - similar to planning - finds best available rate among all valid service providers that meet all constraints - if nothing is found, it will error

                  Recalculate cost - try to recalculate shipment cost for the same (assigned) service provider only - generally used if rate record is changed after shipment planning and we want shipment cost to be recalculated based on new rate definition for same service provider.

                  Regards
                  Nipun

                  Hi Nipun,

                  In case of Assign Rate action present on sell shipment, if new rate not present in system and same rate which present on shipment is still active. If we perform 'assign rate' action, then what is the possibility? Action should be completed without any error as atleast one rate is available in the system or will it throw and error as below.
                  Failed to assign service provider while assigning rate for shipment

                  Thanks,
                  Tejal

                  Comment

                  Working...
                  X